Started about 2 months agoMay 25, 2026Lasted 2 daysMay 25, 20261:00 PMMay 27, 20269:38 PMUTC
Affected
Dashboard
Degraded performance from 1:00 PM to 9:38 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
Mantle has been loading slower than usual over the past couple of days. We're actively working on a fix and will update this page as we make progress. Thanks for your patience.