Started about 2 months agoJune 01, 2026Lasted 4 daysJune 01, 202612:30 PMJune 05, 20268:44 PMUTC
Affected
Usage events
Degraded performance from 12:30 PM to 8:44 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Monitoring
UTC
Monitoring
UTC
Usage event processing is currently delayed a bit. Events are still being received and queued, so nothing is lost and everything will catch up. We're working to get processing back to normal.